WSUS Support Forums: Unexpected Error - WSUS Support Forums

Jump to content

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Unexpected Error

#1 User is offline   drobb 

  • Member
  • PipPip
  • Group: Regular Members
  • Posts: 14
  • Joined: 15-Jun-05

Posted 12 Nov 2007, 04:57

WSUS was working without any problmes before the weekend, nothing has changed on the server however when I try and launch the MMC i get a Unexpected error.

Event Type: Error
Event Source: Windows Server Update Services
Event Category: None
Event ID: 7053
Date: 12/11/2007
Time: 11:55:45
User: N/A
Computer:
Description:
The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists,

Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.


The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists,

Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.


System.ArgumentException -- The specified string is invalid.
Parameter name: Title

Source
Microsoft.UpdateServices.BaseApi

Stack Trace:
at Microsoft.UpdateServices.Internal.StringValidation.ValidateUpdateContainerTitleS
ring(String paramName, String value)
at Microsoft.UpdateServices.Internal.BaseApi.UpdateContainer..ctor(UpdateServer updateServer, GenericReadableRow row)
** this exception was nested inside of the following exception **


Microsoft.UpdateServices.Administration.WsusInvalidDataException -- The specified string is invalid.
Parameter name: Title

Source
Microsoft.UpdateServices.BaseApi

Stack Trace:
at Microsoft.UpdateServices.Internal.BaseApi.UpdateContainer..ctor(UpdateServer updateServer, GenericReadableRow row)
at Microsoft.UpdateServices.Internal.BaseApi.UpdateCategory..ctor(UpdateServer updateServer, GenericReadableRow row)
at Microsoft.UpdateServices.Internal.BaseApi.UpdateCategory.BuildUpdateCategoryColl
ction(GenericReadableRow[] categoryRows, UpdateServer updateServer)
at Microsoft.UpdateServices.Internal.BaseApi.UpdateCategory.GetAll(DateTime fromSyncDate, DateTime toSyncDate, UpdateServer updateServer)
at Microsoft.UpdateServices.Internal.BaseApi.UpdateServer.GetUpdateCategories(DateT
me fromArrivalDate, DateTime toArrivalDate)
at Microsoft.UpdateServices.UI.AdminApiAccess.UpdateManager.GetUpdateCategories(Dat
Time fromArrivalDate, DateTime toArrivalDate)
at Microsoft.UpdateServices.UI.SnapIn.Pages.ServerSummaryPage.GetServerTasks(Update
erverStatus serverStatus)
at Microsoft.UpdateServices.UI.SnapIn.Pages.ServerSummaryPage.backgroundWorker_RunW
rkerCompleted(Object sender, RunWorkerCompletedEventArgs e)

For more information, see Help and Support Center at http://go.microsoft....link/events.asp.

Anyone have any ideas, I have the DB on a seperate SQL server
0

#2 User is offline   Lilith 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 2
  • Joined: 12-Nov-07

Posted 12 Nov 2007, 05:01

Hi Drobb,

i actually posted this error this morning: http://www.wsus.info...showtopic=11126

but there are no replies at the moment!
0

#3 User is offline   jacobgomez 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 3
  • Joined: 12-Nov-07

Posted 12 Nov 2007, 06:58

I'm having exactly the same problem. I installed Windows 2003 Service Pack 2 on the server on Saturday but was able to get into the Administration Console for WSUS after that so I don't think it had anything to with it. I was even able to log in on Sunday and check the status.

When I came in this morning I started getting the Unexpected Errors. I don't know what to do.
0

#4 User is offline   Dan Foster 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 4
  • Joined: 13-Jul-06

Posted 12 Nov 2007, 07:00

I'm receiving the same message but I'm still on WSUS 2.0!
0

#5 User is offline   Dan Foster 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 4
  • Joined: 13-Jul-06

Posted 12 Nov 2007, 07:01

The interesting thing is...this message is only appearing on my wsusadmin "home" page. All other tabs (computers, Updates, Reports, etc.) appear to be functioning properly.
0

#6 User is offline   jacobgomez 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 3
  • Joined: 12-Nov-07

Posted 12 Nov 2007, 07:04

That's truly odd Dan. The unfortunate thing for me is that in WSUS 3.0 I cannot get to the other options in the MMC because the main window errors out. Hopefully someone can make heads or tails of this soon.
0

#7 User is offline   drobb 

  • Member
  • PipPip
  • Group: Regular Members
  • Posts: 14
  • Joined: 15-Jun-05

Posted 12 Nov 2007, 08:40

I have found I get this error only on the server home page, I have found if I click on update services (top of the tree) then select one of the hyperlinks such as computers needing updates, I can then browse the rest of the tree.
0

#8 User is offline   Dirkle 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 1
  • Joined: 12-Nov-07

Posted 12 Nov 2007, 08:45

I also started receiving this error this morning. It only appears when I try to access the product list. We just added a Vista machine for testing and wanted to change options to add Vista to my list of products to download updates for and then this started happening. Everything else seems to be working fine, but any time I try to access the product list (through Products and Classification under Options or through a new update view) it errors out. I tried to use the wizard and it didn't error out, but it did hang on the product list (I was able to click next and continue to the next screen, but wasn't able to actually choose any products.

There is a message on the main screen that 5 new products have been added in the last 30 days (of course I can't see what they are). Could it be a possible issue with one of the new products they added to WSUS?
0

#9 User is offline   o0070 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 3
  • Joined: 20-Aug-04

Posted 12 Nov 2007, 08:49

Same problem in our environment, worked last week, but not yet.
Error only occurs when selecting Options-> Products and classifications.
Doesn't matter if using local installed MMC console or console on server directly.
Deleting subdirectory content ...\Microsoft\MMC -> no change at all.
Same Error Event ID 7053 as described above. Plus Additional information from error message :

Source
Microsoft.UpdateServices.BaseApi

Stack Trace:
at Microsoft.UpdateServices.Internal.StringValidation.ValidateUpdateContainerTitleS
ring(String paramName, String value)
at Microsoft.UpdateServices.Internal.BaseApi.UpdateContainer..ctor(UpdateServer updateServer, GenericReadableRow row)
** this exception was nested inside of the following exception **


System.Reflection.TargetInvocationException -- Exception has been thrown by the target of an invocation.

Source
Microsoft.ManagementConsole

Stack Trace:
at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.OnThreadException(Ob
ect sender, ThreadExceptionEventArgs e)
at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
at System.Windows.Forms.Application.OnThreadException(Exception t)
at System.Windows.Forms.Control.InvokeMarshaledCallbacks()
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
at System.Windows.Forms.ContainerControl.WndProc(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativewindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativewindow.WndProc(Message& m)
at System.Windows.Forms.Nativewindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
** this exception was nested inside of the following exception **


System.Reflection.TargetInvocationException -- Exception has been thrown by the target of an invocation.

Source
Microsoft.ManagementConsole

Stack Trace:
at Microsoft.ManagementConsole.Internal.SnapInMessagePumpProxy.OnThreadException(Ob
ect sender, ThreadExceptionEventArgs e)
at System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
at System.Windows.Forms.Control.WndProcException(Exception e)
at System.Windows.Forms.Control.ControlNativewindow.OnThreadException(Exception e)
at System.Windows.Forms.Nativewindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNat
veMethods.IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Form.ShowDialog(IWin32Window owner)
at Microsoft.ManagementConsole.Internal.ConsoleDialogHost.ShowDialog(WaitCursor waitCursor, ShowDialogCallback callback)
at Microsoft.ManagementConsole.Internal.ConsoleDialogHost.ShowDialog(Form form, WaitCursor waitCursor)
at Microsoft.ManagementConsole.Advanced.Console.ShowDialog(Form form)
at Microsoft.UpdateServices.UI.SnapIn.Pages.SettingsSummaryPage.UpdateCategoryAndCl
ssificationSettingsTitle_LinkClicked(Object sender, LinkLabelLinkClickedEventArgs e)
0

#10 User is offline   thazlett 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 2
  • Joined: 12-Oct-07

Posted 12 Nov 2007, 08:57

Hi Guys

I'm getting this error as well - started around 1400 GMT (we're in the UK). Only occurs when I access the 'Products and Classifications' too, whether it is from the hyperlink on teh front page, from the Options, or trying to create a new Update View. This was working about 3 hours before as we had been checking our current products then (no changes made).
The server still seems operational apart from this - I have made approvals, can create new Update Views based on other criteria, and will be (hopefully) rolling out some patches tonight to some dev boxes.

Looks like we need to talk to MS.
0

#11 User is offline   joseti 

  • Advanced Member
  • PipPipPip
  • Group: Regular Members
  • Posts: 242
  • Joined: 11-Oct-07

Posted 12 Nov 2007, 09:09

Microsoft is researching this and hopes to have something for us shortly.
0

#12 User is offline   Dan Foster 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 4
  • Joined: 13-Jul-06

Posted 12 Nov 2007, 09:15

Good News joseti!!

I have found that I cannot edit my synchronization page either...so my previous statement was incorrect. I can, however, see that machines are getting patched (Reports, Updates, and Computers tabs in WSUS 2.0).
0

#13 User is offline   drbiggly 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 4
  • Joined: 12-Nov-07

Posted 12 Nov 2007, 09:30

I found this forum through Google and of course I'm having the same issues that you folks are all having.

Problems/not working:
1) Cannot click on the ToDo list
2) Cannot edit the Products and Classifications list
3) No longer receiving updates from Microsoft

Working:
1) Syncing with Microsoft and always no new updates (likely has to do with the error in the products list?)
2) Can see which client systems have reported in/are reporting in/etc
3) Basic options, proxies, etc are working

I've gone through and checked my IIS configs though that has never changed, as I'm not doing any webserving from this system and IIS's sole purpose is really for WSUS.

Definitely keeping an eye on this thread. Do any of you folks also subscribe to your server for email updates? I notice that the same time I started having this problem is when I stopped receiving the email updates for New Update Alerts, I only get the Update Status Summary.
0

#14 User is offline   joseti 

  • Advanced Member
  • PipPipPip
  • Group: Regular Members
  • Posts: 242
  • Joined: 11-Oct-07

Posted 12 Nov 2007, 11:27

Here's a fix if you have sql server management studio installed. Otherwise, you'll have to wait for a official fix from Microsoft. You can get sql management studio from here:
http://www.microsoft...;DisplayLang=en

run this command:

USE SUSDB
GO

UPDATE dbo.tbPreComputedLocalizedProperty
SET
Title = REPLACE(Title, '"', '')
, [Description] = REPLACE([Description], '"', '')
WHERE UpdateID = '84A54EA9-E574-457A-A750-17164C1D1679' and RevisionNumber = 101

UPDATE dbo.tbPrecomputedCategoryLocalizedProperty
SET
Title = REPLACE(Title, '"', '')
FROM
dbo.tbPrecomputedCategoryLocalizedProperty clp
INNER JOIN dbo.tbUpdate u ON clp.CategoryID = u.LocalUpdateID
WHERE u.UpdateID = '84A54EA9-E574-457A-A750-17164C1D1679'

UPDATE dbo.tbLocalizedProperty
SET
Title = REPLACE(Title, '"', '')
, [Description] = REPLACE([Description], '"', '')
FROM
dbo.tbLocalizedProperty lp
INNER JOIN dbo.tbLocalizedPropertyForRevision lpr ON lp.LocalizedPropertyID = lpr.LocalizedPropertyID
INNER JOIN dbo.tbRevision r ON lpr.RevisionID = r.RevisionID
INNER JOIN dbo.tbUpdate u ON r.LocalUpdateID = u.LocalUpdateID
WHERE
u.UpdateID = '84A54EA9-E574-457A-A750-17164C1D1679'
AND r.RevisionNumber = 101
0

#15 User is offline   drbiggly 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 4
  • Joined: 12-Nov-07

Posted 12 Nov 2007, 11:44

Thanks for posting that fix! Before I attempt that, I do have a couple of questions:

1) This is from Microsoft right?
2) Since it would appear that the commands above are editing the database that SUS uses, this is a database problem of some sort?
3) Anyone know where the database file is kept for SUS to back it up prior to trying the fix?

I'm hesitant to try a fix without a backup of course. No sense in making WSUS less functional than it already is by a mis-key without having a backup first. :)
0

#16 User is offline   rvalkenburg 

  • Member
  • PipPip
  • Group: Regular Members
  • Posts: 10
  • Joined: 30-Jan-04

Posted 12 Nov 2007, 12:51

Joesti...

That SQL Query seemed to have done the trick on my parent server, I just have to fix my replicas now.

This is an odd error and the fact everyone seemed to get it.

Again, thank you for your help.
0

#17 User is offline   joseti 

  • Advanced Member
  • PipPipPip
  • Group: Regular Members
  • Posts: 242
  • Joined: 11-Oct-07

Posted 12 Nov 2007, 13:18

1.) its part a public fix
2.) its a problem with a update containing a double quote in the title
3.) search for *.mdf to find susdb
0

#18 User is offline   jacobgomez 

  • Newbie
  • Pip
  • Group: Regular Members
  • Posts: 3
  • Joined: 12-Nov-07

Posted 12 Nov 2007, 13:21

I just checked again to see if I could get to the main page in the MMC and it worked beautifully. Microsoft must have fixed something because now I can get around the program without any errors.

I didn't have to update anything in my database.
0

#19 User is offline   joseti 

  • Advanced Member
  • PipPipPip
  • Group: Regular Members
  • Posts: 242
  • Joined: 11-Oct-07

Posted 12 Nov 2007, 13:48

Microsoft fixed the metadata to not contain the double quote. So you can either wait till the next scheduled sync or run the SQL fix.
0

#20 User is offline   zephyrboy 

  • Newbie
  • Pip
  • Group: New Members
  • Posts: 2
  • Joined: 15-Oct-07

Posted 12 Nov 2007, 15:53

I am not running full-blown SQL, but I was able to fix this issue like this:

1) Close the WSUS console.
2) Go to \Documents and Settings\%username%\Application Data\Microsoft\MMC
3) Rename or delete the file "wsus" .
4) Open the WSUS console to make sure everything is working correctly.

You might loose some custom settings, but everything appeared to be the same to me.
0

  • (2 Pages)
  • +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users